Subscribe / Unsubscribe Enewsletters | Login | Register

Pencil Banner

Cisco fixes serious security flaws in networking, communications products

Lucian Constantin | Oct. 25, 2013
Some of the company's new updates address a known vulnerability in Apache Struts.

Struts version 2.3.15.2, which was released in September, made some changes to the DefaultActionMapper "action:" prefix that's used to attach navigational information to buttons within forms in order to mitigate an issue that could be exploited to circumvent security constraints. The issue has been assigned the CVE-2013-4310 identifier.

Struts 2.3.15.3, released on Oct. 17, turned off support for the "action:" prefix by default and added two new settings called "struts.mapper.action.prefix.enabled" and "struts.mapper.action.prefix.crossNamespaces" that can be used to better control the behavior of DefaultActionMapper.

The Struts developers said that upgrading to Struts 2.3.15.3 is strongly recommended, but held back on releasing more details about CVE-2013-4310 until the patch is widely adopted.

It's not clear when or if Cisco will patch CVE-2013-4310 in its products, giving that the fix appears to involve disabling support for the "action:" prefix. If the Struts applications in those products use the "action:" prefix the company might need to rework some of their code.

 

Previous Page  1  2 

Sign up for CIO Asia eNewsletters.