Subscribe / Unsubscribe Enewsletters | Login | Register

Pencil Banner

Microsoft confirms zero-day bug in IE6, IE7 and IE8

Gregg Keizer | Dec. 31, 2012
Microsoft on Saturday confirmed that Internet Explorer (IE) 6, 7 and 8 contain an unpatched bug -- or "zero-day" vulnerability -- that is being used by attackers to hijack victims' Windows computers.

Other researchers claimed that attacks using the IE vulnerability started as early as Dec. 7, and alleged that Chinese hackers were responsible for the CFR website hack.

In an email to Computerworld and in a follow-up blog Saturday, Microsoft said it is working on a patch for IE6, IE7 and IE8. The company did not set a timetable for an update's release, however.

Jonathan Ness and Cristian Craioveanu, engineers on Microsoft's security team, provided some details on the IE flaw in a separate post to the Security Research & Defense blog. "We're working around the clock on the full security update," Ness and Craioveanu wrote.

They also announced the availability of a "shim" that can protect IE6, IE7 and IE8 users if they're running the most up-to-date versions of those browsers.

Shim is a term used to describe an application compatibility workaround. Microsoft has applied shims in the past to help customers ward off active attacks against IE.

The shim will be used as the foundation for a soon-to-be-shipped "Fixit," Microsoft's name for the one-click workarounds it often publishes to automate processes, including security mitigations, that most users would feel uncomfortable doing on their own.

To apply the available shim, for instance, users must download the small files from the SRD blog, then enter one or more strings in Windows' Command Prompt.

This was the second year in a row that Microsoft has had to deal with an emergency update in the waning days of December.

In 2011, the company issued a Dec. 28 security advisory about a flaw in its ASP .Net programming language that hackers could use to cripple website servers. On Dec. 29, 2011, Microsoft released an "out-of-band," or emergency, update.

Microsoft reminded customers that IE9 and IE10 do not contain the vulnerable code, and are safe to use. Windows XP users, however, cannot use either of those browsers, as Microsoft has limited IE9 to Vista and Windows 7, and IE10 to Windows 7 and Windows 8.

 

Previous Page  1  2 

Sign up for CIO Asia eNewsletters.