Subscribe / Unsubscribe Enewsletters | Login | Register

Pencil Banner

Microsoft Edge browser gets its first critical patches

Joab Jackson | Sept. 9, 2015
Microsoft Edge gets 4 security fixes in its first patch Tuesday, while older sibling Internet Explorer got 17.

microsoft logo redwest a

Released a little over a month ago, Microsoft's new Edge browser has gotten its first set of critical security patches.

As part of its monthly round of security fixes, colloquially known as Patch Tuesday, Microsoft released a critical bulletin, MS15-05, with four patches covering vulnerabilities in the Windows 10-only Edge browser.

Overall this month, Microsoft issued 12 bulletins covering 56 vulnerabilities. Five bulletins were deemed as critical, meaning they should be addressed as soon as possible.

In addition to Edge, this month's patches cover issues in Internet Explorer, Windows, Office, Exchange, the .Net framework, the Hyper-V virtual machine, Active Directory, and Skype for Business.

Microsoft built Edge as the next generation browser for Windows, one designed to replace Internet Explorer over time.

All the Edge vulnerabilities Microsoft disclosed this month were also found in Internet Explorer, which was covered by MS15-094, pointed out Wolfgang Kandek, chief technology officer for IT security firm Qualys.

"Someone could attack you, whether you have either Internet Explorer or Edge, using a specially crafted Web page," Kandek said.

The duplicates show the code overlap between Edge and IE, indicating that the engineering team developing Edge used at least part of the code base for IE, Kandek said.

But the fact that Edge had fewer vulnerabilities this month than IE, which had 17, shows that Microsoft's engineering effort in building a more secure browser seems to be paying off, Kandek said.

It also shows how difficult it is to write software that is error-free and immune to attackers, he said.

Because Windows 10 hasn't been widely installed in the enterprise yet, reviewing the Edge bulletin may not be the top priority on administrators' to-do lists.

Instead, the bulletins that they should take a look at first are MS15-097 and MS15-099, which describes a number of critical vulnerabilities found in Office 2007 and 2010, advised Amol Sarwate, Qualys director of engineering.

"There are already attacks going on in the wild" that use these vulnerabilities, Sarwate said. Many are remote code execution vulnerabilities, meaning the user only needs to open a maliciously-crafted Excel or Word document, and the code within can execute actions without the user's knowledge.

Those shops running Microsoft Exchange and Active Directory should also take a close look at MS15-096 and MS15-103, covering Active Directory and Microsoft Exchange, respectively.

The Exchange vulnerability could allow a malicious attacker to gain entry to a user's files through the Outlook Web Access (OWA) client.

The Active Directory flaw makes the software vulnerable to a denial of service (DoS) attacks.

 

1  2  Next Page 

Sign up for CIO Asia eNewsletters.