Subscribe / Unsubscribe Enewsletters | Login | Register

Pencil Banner

Adobe patches Flash to quash last two zero-days unearthed in Hacking Team's cache

Gregg Keizer | July 15, 2015
Adobe today patched Flash Player to quash a pair of zero-day vulnerabilities found in the massive cache of documents hackers stole from the Hacking Team surveillance company.

flash update

Adobe today patched Flash Player to quash a pair of zero-day vulnerabilities found in the massive cache of documents hackers stole from the Hacking Team surveillance company.

Earlier Tuesday, Google patched its Chrome browser with an updated version of Flash, signaling that Adobe would soon follow suit.

But Microsoft dropped the ball, having not only not yet patched Flash in its Internet Explorer 11 (IE11) or the default Edge browser in Windows 10, but ignoring the firestorm about the wave of Flash zero-days that have set some urging users to dump the plug-in.

"Mum's the word about Flash from Microsoft," tweeted Andrew Storms, vice president of security services at San Francisco-based security consultancy New Context. Storms was referring to the omission of any mention of the Flash flaws in the brief blog Tuesday attributed to the Microsoft Security Response Center (MSRC).

"You'd think someone [at Microsoft] would be like, "Oh, like ... um ... Flash is like all on fire all over the Interwebs. Maybe we should like say a few things," Storms added in via instant message.

"Adobe is aware of reports that exploits targeting vulnerabilities affecting Flash Player have been published publicly," the company said in the advisory alerting users that a patched Player was available today.

Flash 18.0.0.209 patched two vulnerabilities, both zero-days -- in other words, vulnerabilities uncovered and public before a fix was issued -- unearthed by researchers who rooted through the 400GB of information leaked after the breach of Italian firm Hacking Team.

Previously, Adobe had acknowledged two zero-days -- the second and third of a troika discovered in the Hacking Team's massive cache -- that went public since late last Friday.

"Critical vulnerabilities (CVE-2015-5122, CVE-2015-5123) have been identified in Adobe Flash Player 18.0.0.204 and earlier versions for Windows, Macintosh and Linux," Adobe had written in an advisory revised Sunday. "Successful exploitation could cause a crash and potentially allow an attacker to take control of the affected system."

Since July 6, researchers poking around the Hacking Team's disclosure have found three unpatched -- zero-day in security speak -- vulnerabilities, triggering calls for users to abandon the popular Flash Player and prompting Mozilla to block all versions of the player in Firefox.

Mozilla took the unusual step, it tweeted today, because "We are committed to protecting our users from security risks. That's why -- following an Adobe alert -- we temporarily blocked #Flash in Firefox."

The open-source developer frequently blocks risky add-ons and plug-ins, and always blocks outdated instances of Flash, but rarely if ever has blocked external components before a new version was available.

 

1  2  Next Page 

Sign up for CIO Asia eNewsletters.